Первоначальная настройка CISCO - CafeTube.ru - Образовательный портал - видео
Добро пожаловать
Вход / Регистрация

Первоначальная настройка CISCO

Первоначальная настройка CISCO, все что помогло мне выкладываю:

Очень часто у новичков возникает вопрос:
«Что нужно настроить на Cisco Catalyst с нуля?»
или встречается запрос в google:
«Скачать дефолтовый конфиг для Cisco Catalyst»
или
«catalyst 2960 2950 3560 ip адрес по умолчанию»
или
«как настроить cisco catalyst «
Попробую немного помочь этим людям file:///F:DOCUME~19335~1LOCALS~1Tempmsohtmlclip1�1clip_image001.gif
Дефолтовых конфигов не бывает, т.к. у каждого своя сеть и свои «правила»
Нету у Cisco IP-адреса по умолчанию (это же не Dlink), все настраивается ручками и сначала через консоль.
Итак, попробуем разобраться в том, что желательно настроить на нулевом Cisco Catalyst ?
Например, часто встречающиеся:
Cisco Catalyst 2950
Cisco Catalyst 2960
Cisco Catalyst 3550
Cisco Catalyst 3560
Cisco Catalyst 3560G
Я использовал Cisco Catalyst 3560G
0. Подключаемся к cisco по консольному кабелю через com порт:
FreeBSD через com порт:
cu -l /dev/cuad0
FreeBSD через переходник USB->Com:
kldload uplcom.ko
kldstat | grep uplcom (убедиться что подгрузился)
подключить переходник к USB порту
cu -l /dev/cuaU0
в Windows можно использовать Hiper Terminal для подключения к com порту
1. Зададим пароль на enable режим
Switch> enable
Switch# configure terminal
Switch(config)# enable password my-secret-password
2. Установим пароль для входа по telnet
Switch(config)# line vty 0 15
Switch(config-line)#password my-telnet-password
3. Сразу разрешим вход по telnet
Switch(config-line)# login
Switch(config)# exit
4. Зашифруем пароли, чтобы по sh run они не показывались в открытом виде
Switch(config)# service password-encryption
5. Зададим имя девайсу, например будет c3560G
Switch(config)# hostname c3560G
6. повесим / присвоим IP-адрес нашему девайсу
c3560G(config)# interface vlan 1
c3560G(config-if)# ip address 192.168.1.2 255.255.255.0
c3560G(config-if)# exit
7. Если вы ошибетесь при наборе чего либо в консоле, то циска начнет пытаться это отрезолвить, чем заставляет вас ждать, выключим эту фичу
c3560G(config)# no ip domain-lookup
8. Зададим имя домена
c3560G(config)# ip domain-name my-domain.ru
9. Зададим IP-адрес DNS сервера
c3560G(config)# ip name-server 192.168.1.15
10. Зададим время
если у вас есть доступный NTP сервер
c3560G(config)# ntp server 192.168.1.1 version 2 source vlan 1
c3560G(config)# ntp clock-period 36029056
c3560G(config)# ntp max-associations 1
где 192.168.1.1 — это IP-адрес NTP сервера
а используя «добавку» source vlan вы можете четко задать номер vlan с IP которого будет отправляться NTP запрос
если нет NTP сервера, то можно задать время вручную, но для этого придется выйти из режима конфигурирования
c3560G(config)# exit
c3560G# clock set 20:00:50 23 Aug 2008
11. Зададим переход с зимнего на летнее время и наоборот
c3560G# configure terminal
c3560G(config)# clock timezone MSK 3
c3560G(config)# clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
12. Сделаем так, чтобы по команде show logging отображалось нормальное время, а не кол-во дней и т.п.
c3560G(config)# service timestamps log datetime localtime
13. Зададим дефолтовые настройки сразу всем портам на девайсе (у меня catalyst 24 порта + 4 SFP)
c3560G(config)# interface range gi 0/1 — 28
c3560G(config-if-range)# description not_used
c3560G(config-if-range)# shutdown
c3560G(config-if-range)# no cdp enable
c3560G(config-if-range)# switchport nonegotiate
c3560G(config-if-range)# switchport mode access
c3560G(config-if-range)# exit
Рекомендую: все неиспользуемые порты держать выключенными, а ещё лучше создать влан (например 999) и все выключенные порты переместить в него:
c3560G(config)# vlan 999
c3560G(config-vlan)# name unused_ports
c3560G(config-vlan)# shutdown
c3560G(config-vlan)# exit
c3560G(config)# interface range gi 0/1 — 28
c3560G(config-if-range)# description not_used
c3560G(config-if-range)# shutdown
c3560G(config-if-range)# no cdp enable
c3560G(config-if-range)# switchport nonegotiate
c3560G(config-if-range)# switchport access vlan 999
c3560G(config-if-range)# switchport mode access
c3560G(config-if-range)# exit
14. Выключим web-интерфейс, командная строка рулит file:///F:DOCUME~19335~1LOCALS~1Tempmsohtmlclip1�1clip_image002.gif
c3560G(config)# no ip http server
15. Зададим gateway по умолчанию (допустим это будет 192.168.1.1, т.к. мы присвоили девайсу IP 192.168.1.2/255.255.255.0)
c3560G(config)# ip default-gateway 192.168.1.1
16. Если этот свич будет моддерживать маршрутизацию (будет router`ом), то включим функцию маршрутизации (если это позволяет сам девайс и его прошивка)
3560G прекрасно справляется с функцией маршрутизации
c3560G(config)# ip routing
c3560G(config)# ip classless
c3560G(config)# ip subnet-zero
17. Если вы выолнили пункт 16-ть, то снова необходимо задать gateway по умолчанию, но уже другой командой
c3560G(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1
18. Настроим access-list для доступа к свичу только с определенных IP-адресов
c3560G(config)# ip access-list standard TELNET
c3560G(config-std-nacl)# permit 192.168.1.1
c3560G(config-std-nacl)# permit 192.168.1.15
c3560G(config-std-nacl)# exit
19. Применим этот access-list
c3560G(config)# line vty 0 15
c3560G(config-line)# access-class TELNET in
20. Зададим timeout неактивности telnet сессии, по истечении указанного времени, если вы в консольке ничего не вводили, то telnet соединение будет автоматически закрываться
c3560G(config-line)# exec-timeout 5 0
c3560G(config-line)# exit
21. Включим SNMP, но только read only (RO) и доступность только с хоста 192.168.1.1
c3560G(config)# snmp-server community RO-MY-COMPANY-NAME RO
c3560G(config)# snmp-server trap-source Vlan1
c3560G(config)# snmp-server source-interface informs Vlan1
c3560G(config)# snmp-server location SWITCH-LOCATION
c3560G(config)# snmp-server contact my-email@my-domain.ru
c3560G(config)# snmp-server host 192.168.1.1 RO-MY-COMPANY-NAME
c3560G(config)# exit
22. Ну и наконец сохраним свои труды
c3560G# copy running-config startup-config
или можно проще и короче file:///F:DOCUME~19335~1LOCALS~1Tempmsohtmlclip1�1clip_image001.gif
c3560G# wri
Море документации по catalyst`ам, и не только по ним, вы можете найти, ессно, на сайте производителя: www.cisco.com
23. Если хочется включить на девайсе ssh, чтобы подключаться к cisco по ssh (если это позволяет установленный IOS), то выполним следущее:
а) Обязательно указываем имя домена (необходимо для генерации ключа) см. пункт 8.
б) cisco(config)# crypto key generate rsa
в) cisco(config)# line vty 0 15
г) cisco(config)# transport preferred none
д) cisco(config)# transport input ssh
е) cisco(config)#transport output ssh

 

////////////////////////////////////////////////////////////////////////////

если вылетает такое: % No password set

делаем следующее, мне помогло

SWITCH_NAME_1>
SWITCH_NAME_1>enable
SWITCH_NAME_1#conf t
SWITCH_NAME_1(config)#enable password

 

///////////////////////////////////////////////

набираем пароль

далее набираем enable или en

далее show mac-address-table
выводит мак адрес и порт на котором он висит

далее conf t
и набираем int fa0/7 попадаем на порт 7
далее speed 10 или 100
wr для записи конфига


информацию об интерфейсе, sh int fa0/1

Для этого в режиме глобальной конфигурации (conf t)
и в режиме конфигурации интерфейса (int f0/1) вводим команды:

speed 10
duplex half

==================================================
Ос - FreeBSD 8.2-RELEASE ядро GENERIC amd64

Ставил из порта с фашего сайта.

При запуске выдается ошибка:
ELF interpreter /libexec/ld-elf.so.1 not found


Сам файл это есть и ссылка в /usr/libexec, как советовали на другох сайтах установимл пакеты для совместимость compat

Надеюсь на помощь...

Похоже, что у вас не установлены 32битные либы, необходимые для работы 32битных приложений в 64битной среде.
Для FreeBSD они обычно идут отдельным набором на установочном диске.

/8.2-RELEASE/lib32/install.sh на установочном диске FreeBSD 8.2
=================================================================

если возникает ошибка:
arpresolve can't allocate llinfo for

решается словом
defaultrouter="23.23.23.23"

=================================================================
при установки /usr/port/net-mgnt/bpft
в дириктории /usr/local/sbin/ лежит trafd.sh он на архитектуре amd64 не работает
нормально виснит и загружает комп на 100%
его надо удалить и поставить из папки которая лежит на компе
у него sh расширения нет тоесть он будет выглядеть просто trafd

=================================================================
Выключить порт
conf t
interface */*
shutdown


Ну соответственно
conf t
interface */*
no shutdown


==================================================================
Изменить скорость в %

Switch(config)# interface FastEthernet 0/1
Switch(config-if)# speed 10
Switch(config-if)# srr-queue bandwidth limit 20

Вначале ограничиваете скорость до 10Mbps а затем говорите, что хотите использовать только 20% от 10Mbps .

отключение bandwidth нужно ввести команду conf t далее (config)#default interface fa0/18
==================================================================

show run interface fa0/18 проверка порта

 

////////////////////////////////////////////////////////

Сброс конфигурации порта Cisco

Часто бывает, что вам нужно сбросить порт свича или роутера после тестирования различных конфигураций к значениям по-умолчанию (сброс порта Cisco к дефолтному).
Чтобы не удалять построчно каждую строку конфигурации, можно применить простую команду сброса конфигурации порта к дефолтной (в привилегированном режиме) default:
#conf term
(config)#default interface fa0/0

Чтобы сбросить несколько портов к дефолтным настройкам, можно использовать команду range. Например, с первого порта по 24-й:
(config)#default interface range fastEthernet 0/1-24

Все очень просто!

 

Написать комментарий

Комментарии

Комментариев нет.

Похожие статьи

  • Полезные фичи

    Параметры индексирования не открывается Запускаем командную строку от имени локального администратора, желательно от друг...

  • В ЧЕМ СМЫСЛ ЖИЗНИ ЧЕЛОВЕКА

    В ЧЕМ СМЫСЛ ЖИЗНИ ЧЕЛОВЕКА Эту статью Вы также можетепрослушать в mp3 формате ПРЕДИСЛОВIЕ К СТАТЬЕ О СМЫСЛЕ ЖИЗНИ Перед ...

RSS